Bu barədə bir neçə gün öncə Twitterdə müzakirə getdi, Mac və Windows üçün həllər təqdim edildi. Ubuntu üçün həlli də mən paylaşdım. Sonradan bəzi problemlərin olduğu barədə məlumat aldım, test edərək həqiqətən də qovluğun yalnız readonly olaraq açıldığını gördüm. Ona görə də tələsik bir həll olaraq hazırki unix kodları paylaşıram.
İmkan olsa bu kodları shell skript formasına salaraq launcher düzəldib hazır bir kliklə Box.net-i Ubuntuya qoşan bir həll hazır edəcəm.
Qısaca məlumat verim ki Box.net cloud file storage sistemidir(Bulud fayl saxlama sistemi) Bu sistem sizin qovluqlarınız kompüterinizdə yox, internet üzərindən başqa serverlərdə saxlanılır, bu sizi tək kompüterdən azad edir, istənilən kompüterdən öz fayllarınıza ulaşa bilirsiniz.) Box.net-dən başqa bu sahədə əsas məşhur servis Dropbox-dur.
İndi isə kodlara keçək.  Ubuntuda ctrl+alt+T ilə Terminalı açırıq. Bu 3 sətri ardıcıl icra edirik:

sudo mkdir /media/box.net
sudo mount -t davfs https://www.box.net/dav /media/box.net 
sudo chown -R sizin_user_adiniz  /media/box.net

Burada sizin_user_adiniz hissəsinə öz Ubuntu istifadəçi adını yazın. Məsələn mən default olaraq elvin:elvin yazıram. İstifadəçi adı:İstifadəçi qrupu adı.
İkinci sətrin icrası zamanı sizdən box.net login parolu istəniləcək ki, onları daxil etmək lazımdır. Bir də kimdə ki davfs quraşdırılmayıb(hansı ki default quraşdırılmış olmalıdır) ondan davfs quraşdırılması tələb olunacaq. Onu da bir sətirlə həll edə bilərsiniz:

sudo apt-get install davfs2

Vəssalam. Hər hansı problem çıxsa şərhlər bölməsində yaza bilərsiniz.
Shell skriptdə təcrübəsi olanlar bu kodu launcher formasına salıb linkini şərhlər bölməsində yazsa, daha əla olar 🙂 (Sadə shell kod lazımdır, launcherə basanda .SH faylını çağırsın, prompt ilə Ubuntu root parolu, boxnet login parolu tələb olunsun, submit etdikdə yuxarıda yazdığım 3 sətir icra olunsun, vəssalam)

Leave a reply

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> 

required